# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:src|action|href)=[\'\"]\K/(?!/)[^\'\"]*"
test_str = ("<img src=\"/relative/url/img.jpg\" />\n"
"<form action=\"/\">\n"
"<form action=\"/contact-us/\">\n"
"<a href='/relative/url/'>Note the Single Quote</a>\n"
"<img src=\"//site.com/protocol-relative-img.jpg\" />\n")
subst = "https://example.com$0"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.