package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{{(.*?)}}`)
var str = `{{ url('mr_message_read', {id: message.id}) }}
{{ object.property }}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}