$re = '/^(?:(\d)(?!\d*\g{-1}))+$/m';
$str = '12
34
44
55
65
654
6554
76543
765433';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);