#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[A-Za-z0-9]).{3,30}$"
Local $sString = "ben" & @CRLF & _
"ab" & @CRLF & _
"ben " & @CRLF & _
"ben_franklin" & @CRLF & _
"ben@" & @CRLF & _
"%#$" & @CRLF & _
"ben#franklin" & @CRLF & _
"be'franklin" & @CRLF & _
"&%^$@#!*&^"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")