# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\+?\d{0,2})?[\D]?\(?(\d{3})\)?[\D]?(\d{3})[\D]?(\d{4})$/$1 $2-$3-$4/gm;t' <<< "(000) 000 0000
(000) 000-0000
(000)000 0000
(000)000-0000
(000)0000000
+0 (000) 000-0000
+0 000 000 0000
+0 000-000-0000
+0-000-000-0000
+00 (000) 000-0000
+00 000 0000000
+00 0000000000
+0000000000
+000000000000
0 (000) 000-0000
0 (000)-000-0000
0 0000000000
0-000-000-0000
000 000 0000
000 000-0000
000-000 0000
000-000-0000
000-0000000
000.000.0000
000000-0000
0000000000"