$re = '/([A-Z0-9 #]+) \[([A-Za-z0-9 .]+)\]([\S])/m';
$str = '- MAN [on radio]: The signal is breaking up.
MAN #2 [on radio]: Stay on him.
';
$subst = "[\L$1\E $2]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;