package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^.]*\.[^.]{2,3}(?:\.[^.]{2,3})?$`)
var str = `http://google.com
http://www.google.com
http://abc.cde.google.com
http://google.co.uk
http://www.google.com.au
http://www.mysite.info
http://www.mysite.business
http://www.gmx.de
http://localhost
Optional:
http://google.com:8080
http://www.google.com?q=abc
http://www.google.com/smth
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}