re = /[^.]*\.[^.]{2,3}(?:\.[^.]{2,3})?$/m
str = 'http://google.com
http://www.google.com
http://abc.cde.google.com
http://google.co.uk
http://www.google.com.au
http://www.mysite.info
http://www.mysite.business
http://www.gmx.de
http://localhost
Optional:
http://google.com:8080
http://www.google.com?q=abc
http://www.google.com/smth
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end