using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(\S+(?:\s+\S+)*)\s*";
string substitution = @"\1";
string input = @" somet hing ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}