$re = '/\s*(\S+(?:\s+\S+)*)\s*/';
$str = ' somet hing ';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;