import Foundation
let pattern = #"\s*(\S+(?:\s+\S+)*)\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" somet hing "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)