$re = '/(?<!GAS )TOTAL\s*(\$\d+\.\d+)/';
$str = 'SPEEDWAY 3007906
Wallace NC 28466
TRAM: 1086244
9/17/2017 2:12 pm
Pump 08
Regular Unleaded
8,716 @ $2,639/6131
GAS TOTAL $23.00
TAX $0.03
TOTAL $23.80
Uisa ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);