package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)id="loginToken".*?value="(.*?)"`)
var str = `<span id="loginToken"><input name="__RequestVerificationToken" type="hidden" value="kL5UknRMXsBy5QUMtDFPuBwESd89jK5l1VyF7SliGL8g0NCE-pnbowPMPtEMpi2Nmm9F_626FN-cQ6-miwS-CXXkQUM1" /></span>
<span id="registerToken"><input name="__RequestVerificationToken" type="hidden" value="JDJD9khCZNjXeFGLMcBbqDqNmgR19Z-wy4FueH1CkWCdQQry_cgnKHLuj7uyrquk_gzDotKxN1ZQO8rPEc3fsH21uXc1" /></span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}