const regex = /id="loginToken".*?value="(.*?)"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('id="loginToken".*?value="(.*?)"', 'gm')
const str = `<span id="loginToken"><input name="__RequestVerificationToken" type="hidden" value="kL5UknRMXsBy5QUMtDFPuBwESd89jK5l1VyF7SliGL8g0NCE-pnbowPMPtEMpi2Nmm9F_626FN-cQ6-miwS-CXXkQUM1" /></span>
<span id="registerToken"><input name="__RequestVerificationToken" type="hidden" value="JDJD9khCZNjXeFGLMcBbqDqNmgR19Z-wy4FueH1CkWCdQQry_cgnKHLuj7uyrquk_gzDotKxN1ZQO8rPEc3fsH21uXc1" /></span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}