// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)id="loginToken".*?value="(.*?)""#).unwrap();
let string = "<span id=\"loginToken\"><input name=\"__RequestVerificationToken\" type=\"hidden\" value=\"kL5UknRMXsBy5QUMtDFPuBwESd89jK5l1VyF7SliGL8g0NCE-pnbowPMPtEMpi2Nmm9F_626FN-cQ6-miwS-CXXkQUM1\" /></span>
<span id=\"registerToken\"><input name=\"__RequestVerificationToken\" type=\"hidden\" value=\"JDJD9khCZNjXeFGLMcBbqDqNmgR19Z-wy4FueH1CkWCdQQry_cgnKHLuj7uyrquk_gzDotKxN1ZQO8rPEc3fsH21uXc1\" /></span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}