use strict;
my $str = 'kind: ConfigMap
apiVersion: v1
metadata:
name: {{ .Release.Name }}-nginx-index-html-configmap
data:
startRegexMatch.html: |
<!DOCTYPE html>
<html>
<head>
<title>Up & Running!</title>
<style>
body {
width: 60em;
margin: 0 auto;
font-family: Tahoma, Verdana, Arial, sans-serif;
}
</style>
</head>
<body>
<h1>Up & Running!</h1>
<pre style="float:left;">
888 888 888 d88P 888 8888888P" 8888888P" 888 888 888d88888b888 888 888 8888888P" 8888888b "Y88b. 888
8888888888 88888888 "Y8888P" d88P 888 888 T88b 888 T88b "Y88888P" 888P Y888 "Y88888P" 888 T88b 888 Y88b "Y8888P" 888 </pre>
</body>
</html>
stopRegexMatch:';
my $regex = qr/(?m)(?<=^(\s*)(?:[^\s:][^:\r\n]*)?: \|\s*)(?:\r?\n(?!\1\S).*)+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}