package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_[io]$`)
var str = `my_input_port_i`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}