const regex = /\bcp\h+(filename\d+)\*(\.csv)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bcp\\h+(filename\\d+)\\*(\\.csv)', 'gm')
const str = `cp filename1*.csv
cp filename2*.csv
cp filename3*.csv
`;
const subst = `$0 $1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);