#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?:https?:\/\/)(?:w{3}\.)?([^\r\n]+?)\.([a-z0-9]{2,6})(\.[a-z0-9]{2,6})?\/?(.*)$"
Local $sString = "https://stackoverflow.com/questions/ask" & @CRLF & _
"https://stackoverflow.co.uk/questions/ask" & @CRLF & _
"https://www.stackoverflow.com/questions/ask" & @CRLF & _
"http://www.stackoverflow.co.uk/questions/ask" & @CRLF & _
"http://www.stackoverflow.co.uk/" & @CRLF & _
"http://www.stackoverflow.co.uk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")