import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?:https?:\\/\\/)(?:w{3}\\.)?([^\\r\\n]+?)\\.([a-z0-9]{2,6})(\\.[a-z0-9]{2,6})?\\/?(.*)$";
final String string = "https://stackoverflow.com/questions/ask\n"
+ "https://stackoverflow.co.uk/questions/ask\n"
+ "https://www.stackoverflow.com/questions/ask\n"
+ "http://www.stackoverflow.co.uk/questions/ask\n"
+ "http://www.stackoverflow.co.uk/\n"
+ "http://www.stackoverflow.co.uk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}