using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<SimpleData name="")NAME("">[\S\s\n]*?</SimpleData>)";
string substitution = @"$1COUNTY$2";
string input = @"<SimpleData name=""NAME"">Angelina</SimpleData>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}