$re = '/\d{3,5}-\d{3,5}|\d{5}(?![A-Z]{2})/';
$str = '12345 Example Street, NY 10019 United States';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);