#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{14}\s.*(?:\n*(?!^\d{14}).*)*)"
Local $sString = "59105999000321 My value start" & @CRLF & _
"with new line number" & @CRLF & _
"weqweqwoe" & @CRLF & _
"qweqoweqioeq" & @CRLF & _
"qweiqwiequiweqe" & @CRLF & _
"oqweiqowpeqiweqpwoe" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"12105999000343 AAAAAasasas asdasdasd" & @CRLF & _
"32105999000323 asdasxasxasx asdasd" & @CRLF & _
"" & @CRLF & _
"weqpowepoqwiq" & @CRLF & _
"" & @CRLF & _
"qwpeqẃepoqwepqy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")