use strict;
my $str = '59105999000321 My value start
with new line number
weqweqwoe
qweqoweqioeq
qweiqwiequiweqe
oqweiqowpeqiweqpwoe
12105999000343 AAAAAasasas asdasdasd
32105999000323 asdasxasxasx asdasd
weqpowepoqwiq
qwpeqẃepoqwepqy';
my $regex = qr/(\d{14}\s.*(?:\n*(?!^\d{14}).*)*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}