import Foundation
let pattern = #"(\d{14}\s.*(?:\n*(?!^\d{14}).*)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
59105999000321 My value start
with new line number
weqweqwoe
qweqoweqioeq
qweiqwiequiweqe
oqweiqowpeqiweqpwoe
12105999000343 AAAAAasasas asdasdasd
32105999000323 asdasxasxasx asdasd
weqpowepoqwiq
qwpeqẃepoqwepqy
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)