using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?si)(.*?[_\s]Arve number[\s_:.]*(^TÄNAME))(?<arvenumber>[^\s_]+).*?";
string input = @"20309 NARVA
Arve number:_21954901
Arve number. Täname.
Kliendi number:_11654
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}