const regex = /(?=\[)[a-zA-Z\W\s\n\d]+(?=\])./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=\\[)[a-zA-Z\\W\\s\\n\\d]+(?=\\]).', 'gm')
const str = `{
“documents”: [
{
“workerName”: “some name”,
“fuelCardId”: "443345 ",
“fuelLimit”: 120,
“documentID”: “75fb1ba5-1aef”
},
{
“workerName”: “some name”,
“fuelCardId”: "4534564 ",
“fuelLimit”: 360,
“documentID”: “629e0056-7235”
},
{
“workerName”: “some name”,
“fuelCardId”: "4564564 ",
“fuelLimit”: 899.9,
“documentID”: “3444bda1-d893”
}
]
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}