package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[[:upper:]][[:alpha:]]*\b`)
var str = `Abć,ĄBC?AbĆ,Abc123, Abc_345, abc.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}