// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\((\d\d\d\d[abcd]*)\)").unwrap();
let string = "Especialista em saúde pública (DGS, 2019) De acordo com os dados do Inquérito Alimentar Nacional [IAN-AF] (2017), constata-se que ca (DGS , 2019).De acordo com osata-se que ca ()(A1DGS,2019). Do Inquérito Alimentar Nacional [IAN-AF] (2017), constata-se que 017), que ca (DGS , 2019).Do Inquérito Alimentar Nacional De acordo com os dados do Inquérito Alimentar Nacional [IAN-AF] (2017), constata-se que (DGS , 2019b) De acordo com os dados do Inquérito Alimentar Nacional [IAN-AF] (2017), constata-se que os hábitos alimentares são mais desequilibrados nas crianças e adolescentes. No que se refere à ingestão co
O método exposi () tivo foi o método pedagógico utilizado, nas sessões que foram realizadas em todos os context (Costa, Nunes, Duarte & Pereira 2012). Par os de esto, sendo este () utiliado como atividade didática principal na transmissão de conceitos e informações. (Andrade, Porto, Lima, Santos, Pinto & Medeiros, 2016:330). Neste
Deste modo, nas váriança conhece o mundo à sua volta e desenvolve a sua personalidade, entre estes hábitosade didática principal na transmissão de conceitos e informações. (Andrade, Porto, Lima, Santos, Pinto & Medeiros, 2016d;1). Neste
Deste modo, nas váriança conhece o mundo à sua volta e desenvolve a sua personalidade, entre estes hábitos está o de está o de se alimentar. A nutrição desempenha papel fundamental para a qualidade de vida, uma vez que contribui para o bem-estar físico e mental (Santos, Vitola, Arrieira, Chagas, Gomes & Pereira, 2014). Ausência de aleitamento materno aumenta o seu risco (DGS, 2019b). Num estudo desenvolvido pela OMS, observou-se uma prevalência maior de obesidade infantil entre as crianças que nunca foram amamentadas e também nas que foram amamentadas menos do que 6 meses (Rito et al., 2019). É crucial que se aposte na prevenção da obesidade na infância, pois as crianças obesas têm uma maior probabilidade de virem a ser adultos obesos.tem como inteno () compreender fenmenos vividos por pessoas, categoriar uma populao ou conceptualiar uma situao. (Fortin, 2009: 221). Des
";
let substitution = "(Ref Autores:\\1; Ano:\\2; Página:\\4)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}