// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""((?:\\.|[\w\W])*?)"|(?:@\S+)?[\[{(].*?[\]\})]\S*|\S+"#).unwrap();
let string = "/tellraw @a[name=\"Arie1906\", c=1] ~13 ~~ \"quoted \\\"你好\\\"\" {\"rawtext\": [{\"text\":\"§bI am blue\"}]} ASDA kjhkdjah [BE QUOTA] @[adada ad] []abc @Arie1906";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}