$re = '/^[1-99]?@talentlitmus.com$/m';
$str = '1@talentlitmus.com
abc@talentlitmus.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);