// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[^\n\/\\]+|\\[\\\/]?)+").unwrap();
let string = "aaaa/bbb\\/ccc
this/is\\/a/\\/str\\\\/ing
aaaa/bbb\\\\/ccc/ddd\\/eee/fff/ggg
aaaa/\\bbb
this/is\\/a/dumb/str\\\\/ing";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}