re = /(\d{4}).(\(.*?\)).(?:\(.*\)).-.(\d+\.)?(\d+\.)?(\d+\.)?(\*|\d+)(?:.*?)(?:(\w+).Edition)(?:.*?)(?:Windows.(\w+.\d+.\w+))/m
str = 'Microsoft SQL Server 2012 (SP4-GDR) (KB4583465) - 11.0.7507.2 (X64) Nov 1 2020 00:48:37 Copyright (c) Microsoft Corporation Standard Edition (64-bit) on Windows NT 6.3 <X64> (Build 14393: ) (Hypervisor)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end