$re = '/^(?:ISBN(?:-13)?:? )?(?<gs1>\d{3})(?:(?<number>\d{9})|(?=[\d -]{14}$)[ -](?<registrationGroup>\d{1,5})[ -](?<registrant>\d{1,7})[ -](?<publication>\d{1,6})[ -])(?<checkDigit>\d)$/m';
$str = '9781861978769
97818619787659
978186197879
978-1-86197-876-9
978-1-86197-87-9
978-1-86197-8765-9
978-186197-876-9
978-186197-8-76-9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);