#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)type = (?<type>\S*)|count = (?<count>\d+)|destinations = (?<destinations>\S*)"
Local $sString = "string1 = """" & @CRLF & _
"Name: default" & @CRLF & _
"type = Route" & @CRLF & _
"status = 0" & @CRLF & _
"count = 5" & @CRLF & _
"enabled = False" & @CRLF & _
"start_time = 18:00:00" & @CRLF & _
"end_time = 00:00:00" & @CRLF & _
"destinations = default" & @CRLF & _
"started = False" & @CRLF & _
""""" & @CRLF & _
"" & @CRLF & _
"string2 = """" & @CRLF & _
"Name: default" & @CRLF & _
"type = Route" & @CRLF & _
"status = 0" & @CRLF & _
"enabled = False" & @CRLF & _
"start_time = 18:00:00" & @CRLF & _
"end_time = 00:00:00" & @CRLF & _
"destinations = default" & @CRLF & _
"started = False" & @CRLF & _
""""" & @CRLF & _
"" & @CRLF & _
"type, count and destinations"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")