// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[1-9]{1}$|^[1-3]{1}[0-9]{1}$|^4{1}[0-5]{1}$").unwrap();
let string = "1
2
74
45
46
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}