using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(?=\swifi\s\d{3})|^.*(?=\s\d{3})";
string input = @"iphone 13 256gb - midnight
iphone 13 pro max 256gb - sierra blue
iphone 13 pro 128gb - graphite
galaxy tab a8 wifi 128gb - grey";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}