const regex = /^.*(?=\swifi\s\d{3})|^.*(?=\s\d{3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(?=\\swifi\\s\\d{3})|^.*(?=\\s\\d{3})', 'gm')
const str = `iphone 13 256gb - midnight
iphone 13 pro max 256gb - sierra blue
iphone 13 pro 128gb - graphite
galaxy tab a8 wifi 128gb - grey`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}