$re = '/^.*(?=\swifi\s\d{3})|^.*(?=\s\d{3})/m';
$str = 'iphone 13 256gb - midnight
iphone 13 pro max 256gb - sierra blue
iphone 13 pro 128gb - graphite
galaxy tab a8 wifi 128gb - grey';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);