using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*([a-zA-Zа-яёЁ]){2,}.*";
string input = @"723374374er347
8374r8787rr878
74673не34677
37467364734r34
34737r8878r87r";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}