re = /Initiated logon request((?!Received logon)[\s\S])*Received logon/m
str = '<20170503-18:19:09, FIXT.1.1:BANZAI->EXEC, event> (Initiated logon request)
<20170503-18:19:09, FIX.4.4:BANZAI->EXEC, incoming> (8=FIX.4.4☺9=67☺35=A☺
34=177☺49=EXEC☺52=20170503-18:19:09.298☺56=BANZAI☺98=0☺108=30☺10=092☺)
<20170503-18:19:09, FIX.4.4:BANZAI->EXEC, event>
(Received logon) fdsfhffghgfhgjgf 177☺49=EXEC☺52=20170503-18:19:09.298☺
56=BANZAI☺98 (Received logon) more stuff after this....'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end