package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((https?):\/\/)?(www.)?[a-z0-9]+\.[a-z]+(\.[a-zA-Z0-9#]+\/?)?[\/]?+[a-zA-Z0-9]*$`)
var str = `http://www.goo.com/
https://www.goo.com/
www.goo.com.dsdsas
http://szgmc.aiwa.ai
www.asd.aiwa.ai/IKDS23asdasd
szsacgmc.aiwa
szgsdmc.aiwa.ai
szgcsamc.aiwa.ai/
.szgacascmc.aiwa.ai`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}