import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((https?):\\/\\/)?(www.)?[a-z0-9]+\\.[a-z]+(\\.[a-zA-Z0-9#]+\\/?)?[\\/]?+[a-zA-Z0-9]*$";
final String string = "http://www.goo.com/\n"
+ "https://www.goo.com/\n"
+ "www.goo.com.dsdsas\n"
+ "http://szgmc.aiwa.ai\n"
+ "www.asd.aiwa.ai/IKDS23asdasd\n"
+ "szsacgmc.aiwa\n"
+ "szgsdmc.aiwa.ai\n"
+ "szgcsamc.aiwa.ai/\n"
+ ".szgacascmc.aiwa.ai";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}