const regex = /class(?=="(?:field|.*?\sfield|field\s.*?|.*?\sfield\s.*?)")/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('class(?=="(?:field|.*?\\sfield|field\\s.*?|.*?\\sfield\\s.*?)")', 'g')
const str = `Ex1: should match both of these:
<div class="something else field">Foo</div>
<div class="field something else">Foo</div>
<span class="field">Bar</span>
<span class="foo field bar">Bar</span>
Ex2: should not match
<div class="baseball-field baz">Baz</div>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}