$re = '/(?<!\S)\$\d{1,3}(?:,\d{3})*(?:\.\d+)?(?!\S)/m';
$str = '$123
$123.456
$123,456
$123,456.789
$12,000,000
aaaa$42,000,00
$42,000,000aaa
aaa$42,000,000aaaa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);