use strict;
my $str = '$123
$123.456
$123,456
$123,456.789
$12,000,000
aaaa$42,000,00
$42,000,000aaa
aaa$42,000,000aaaa';
my $regex = qr/^\$\d{1,3}(?:(?:\.|\,)\d{3})*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}