$re = '/^(Abc_\d{2})(?:_(BeispielText1))?/m';
$str = 'Abc_01_BeispielText1
Abc_02';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);