#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!https:\/\/steamcommunity\.com$)(^(https?:\/\/)(st[\w]+)co((m|n){1,})([\w]+)\.(.*){1,}\.?(.*){1,})"
Local $sString = "https://steamcommunity.com" & @CRLF & _
"http://steanconnumity.ru" & @CRLF & _
"http://google.com" & @CRLF & _
"https://stemcomnunity.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")