Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^([#$%*& ])(?<name>[A-Za-z]+)\1=(?<length>[0-9]+)!!(?<code>.*$)
/
gm
Input 1
1
New
Mike??Hailwood=5!![pliu #SteveHislop#=16!!df%TU[Tj(h!!TT[S *DavMolyneux*=15!!efgk#'_$&UYV%h% RichardQ^uayle=16!!fr5de5kd