#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\d)(?!0(?![.]))(?:\d{0,3})(?:[.]\d{1,3})?$"
Local $sString = "111" & @CRLF & _
"" & @CRLF & _
"111.11" & @CRLF & _
"" & @CRLF & _
"11.1" & @CRLF & _
"" & @CRLF & _
"1.1" & @CRLF & _
"" & @CRLF & _
"11.111" & @CRLF & _
"" & @CRLF & _
"0.1" & @CRLF & _
"" & @CRLF & _
"1.1" & @CRLF & _
"" & @CRLF & _
"1.233" & @CRLF & _
"" & @CRLF & _
"0.111" & @CRLF & _
"" & @CRLF & _
"001.1" & @CRLF & _
"" & @CRLF & _
"1111" & @CRLF & _
"" & @CRLF & _
"11.4444" & @CRLF & _
"" & @CRLF & _
"1111.11" & @CRLF & _
"" & @CRLF & _
"1111.1111"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")